h1

Configurando modem USB ZyXEL 630 en Ubuntu

30 octubre, 2007
Introducción

Si hay algo indispensable hoy en día en una computadora, eso es la posibilidad de tener acceso a Internet.

Muchos de los usuarios de Ubuntu tienen la suerte de que el Sistema Operativo les instale por defecto la conexión, pudiendo usarla hasta desde el LiveCD, pero otros no corremos con la misma ventaja y necesitamos configurar el modem para que este funcione como corresponde.

Este es el caso del modem USB ZyXEL 630, que distribuye los queridos amigos de Telefónica de Argentina para usar su servicio de banda ancha, Speedy.

Para todos aquellos que tengan el mismo problema que tuve yo, el mismo que tienen miles de argentinos. Por esta razón, condor, un usuario de LUGMen Forum, Foro del Grupo de Usuarios de Software Libre de Mendoza, se decidió a crear un “HowTo” en el cual explica detalladamente cómo lograr que nuestro modem funcione correctamente bajo Ubuntu.

 

Archivos necesarios

Para comenzar vamos a necesitar dos cosas importantísimas:

1 – El firmware del modem: que vendría a ser una especie de intermediario entre el modem y las ordenes que emitimos [para más información: firmware (wikipedia)].

Tenemos dos opciones para obtenerlo: la primera y más complicada sería obtenerlo a partir del driver para Windows; la segunda es descargarlo directamente desde éste link que amablemente nos brinda condor.

2 – El paquete br2684ctl: necesario para la instalación de modems USB. Esta disponible en los repositores de Ubuntu, pero debido a que no tenemos acceso a estos los tendremos que obtener de antemano.

Nuevamente condor nos facilita los archivos:

 

Instalación

El proceso puede resumirse en 10 pasos sumamente sencillos:

1- Desconectamos el modem;

2- Iniciamos Ubuntu y abrimos la consola;

3- Copiamos el firmware del modem (cxacru-fw.bin) a la carpeta que contiene todos los firmware’s del sistema, /lib/firmware:

cd lugardendeseencuentrecxacru-fw.bin

sudo cp cxacru-fw.bin /lib/firmware

4- Conectamos el modem y al poco tiempo veremos como se enciende.

5- Instalamos el paquete br2684ct, para esto hay dos opciones, haciendo doble click en el icono, o desde consola, dependiendo de la versión:

sudo dpkg -i br2684ctl_20040226_1_i386.deb
sudo dpkg -i br2684ctl_20040226-1_amd64.deb

6- Configuramos los datos de nuestra conexión a internet. Para eso creamos dsl-provider, en /etc/ppp/peers:

sudo gedit /etc/ppp/peers/dsl-provider

Pegamos este contenido:

noipdefault
defaultroute
replacedefaultroute
hide-password
noauth
persist
usepeerdns
plugin rp-pppoe.so nas0
user "xxxxxx"
password "xxxxxx"

En el lugar de las xxxxxx completamos con nuestra información personal, en mi caso “minúmerodeteléfono@speedy” y “micontraseña”.

7- Creamos otro archivo (un script) que deberemos ejecutar para conectarnos. Se llamará iniciarmodem y estará alojado en /etc/init.d:

sudo gedit /etc/init.d/iniciarmodem

Pegamos este contenido:

#!/bin/bash
VPI=8
VCI=35
COUNT=0
ISP=dsl-provider
modprobe ppp_generic
modprobe pppoatm
modprobe pppoe
modprobe br2684
while [[ $((COUNT++)) -lt 40 ]]
do
SYNC=$(dmesg | grep 'ADSL line: up')
if [ ! -z "$SYNC" ]
then
br2684ctl -b -c0 -a $VPI.$VCI
sleep 3
ifconfig nas0 up
sleep 10
pon $ISP
exit 0
fi
sleep 5
done
echo "The SpeedTouch firmware did not load"

Si tu proveedor no es Speedy, modifica los valores VPI= y VCI= por los correctos. En Telecom suele ser VPI=0 y VCI=33, pero ahora tambien anda con los valores de Speedy
En Windows se pueden obtener en la utilidad que trae el modem (ZyXEL ADSL USB Modem Control Panel; Configuracion de protocolo; Circuito Virtual 0).

8- También es necesario crear otro script para que el modem funcione en segundo plano. Para eso creamos iniciarmodembackground en /etc/init.d:

sudo gedit /etc/init.d/iniciarmodembackground

Ingresamos este contenido:

#!/bin/bash
/etc/init.d/iniciarmodem &

9- Configuramos el inicio automático del modem cuando encendamos la computadora, para esto le daremos permiso de ejecución a los dos últimos archivos creados y crearemos un acceso directo en /etc/rc2.d, donde se guardan los accesos a los programas que se deben ejecutar al iniciar el S.O.:

cd /etc/init.d
sudo chmod +x iniciarmodem
sudo chmod +x iniciarmodembackground
cd /etc/rc2.d
sudo ln -s /etc/init.d/iniciarmodembackground S95iniciarmodem

10- Reiniciamos o ejecutamos desde consola este comando:

sudo /etc/init.d/iniciarmodem

 

Una vez realizada esta última acción estaremos conectados a Internet.

Tips

Para desconectarse usaremos:
sudo poff dsl-provider
Y para conectarnos nuevamente:
sudo pon dsl-provider

Este manual es una adaptación del realizado por condor para LUGMen Forum. a quien agradezco por dejar que muchos disfrutemos de este excelente S.O.

Cualquier clase de duda o problema remitanse al post linkeado más arriba, que él amablemente sabrá responderles.

Anuncios

18 comentarios

  1. Este procedimiento tambien sirve para el modem Zyxel Prestige 600 ??


  2. La verdad que no lo sé, sería interesante que probaras y nos contaras ^^.


  3. MMM al intentar hacer el primer paso…

    me aparece que el archivo no esta en el directorio o fichero.. algo asi .. q puede ser?


  4. a q t refieres con esto???

    cd lugardendeseencuentrecxacru-fw.bin

    soy novato en esto.. tengo ubuntu gutsy y no se q hacer


  5. @sebastian: el primer paso es bajar el firmware y acabo de comprobar que está disponible.

    Con respecto a “cd lugardendeseencuentrecxacru-fw.bin” me refiero a que debemos abrir desde consola el directorio en el que se encuentra el archivo cxacru-fw.bin, es decir, el firmware. El comando cd en consola simboliza una apertura, a continuación de este, el directorio a abrir. Un ejemplo podría ser:

    cd /home/sebastian/modem


  6. ok lo intentare ahora… y te digo como me fue! 😉


  7. Ya, te cuento, hice todo lo que dices pero al momento de iniciar el modem me arroja el sgte error:

    sebastian@sebast:~$ sudo /etc/init.d/iniciarmodem
    [sudo] password for sebastian:
    : not found/iniciarmodem: 1: Código:
    not found.le ppp_generic
    not found.le pppoatm
    not found.le pppoe
    not found.le br2684
    /etc/init.d/iniciarmodem: 26: Syntax error: end of file unexpected (expecting “then”)

    me puedes ayudar para solucionarlo???


  8. No te preocupes, ya conseguí ayuda


  9. Llegué tarde, perdón ^^, igualmente no manejo la parte más técnica, por eso dejé el link al foro de donde lo extraje, como me pidió el autor, para que puedan consultar ese tipo de cuestiones 😉 .


  10. pucha sabes despues de arreglar una serie de cosas… igual me volvio a aparecer un problema.. y me dice que el script no existe , lo he revisado mil veces… y está todo bien…

    soy de chile, y tengo el mismo modem… uso gutsy gibbon, tendras alguna solucion?


  11. Si sebastian, por el momento te aconsejo que sigas la guia original de condor (http://foro.lugmen.org.ar/viewtopic.php?t=40&start=0&postdays=0&postorder=asc&highlight=&sid=7c4c23d4a4c7dbe0acf36aa393b56bc3), ya que en mi adaptación parece haber algún que otro problema en los scripts (los copia de manera diferente, tengo que tratarlo puntualmente…).

    Intenta de esa manera y si no tienes resultados me dejas otro comentario 😉 .


  12. pues efectivamente estaba copiado de manera distinta… pues adivina q paso!! me salio otro error 😦

    sebastian@sebast:/etc/rc2.d$ sudo /etc/init.d/iniciarmodem
    /etc/init.d/iniciarmodem: line 12: : orden no encontrada
    /etc/init.d/iniciarmodem: line 13: : orden no encontrada
    /etc/init.d/iniciarmodem: line 14: : orden no encontrada
    /etc/init.d/iniciarmodem: line 15: : orden no encontrada
    /etc/init.d/iniciarmodem: line 16: : orden no encontrada
    /etc/init.d/iniciarmodem: line 17: : orden no encontrada
    /etc/init.d/iniciarmodem: line 18: : orden no encontrada
    /etc/init.d/iniciarmodem: line 19: : orden no encontrada
    /etc/init.d/iniciarmodem: line 20: : orden no encontrada
    /etc/init.d/iniciarmodem: line 21: : orden no encontrada
    /etc/init.d/iniciarmodem: line 22: : orden no encontrada
    /etc/init.d/iniciarmodem: line 12: : orden no encontrada
    /etc/init.d/iniciarmodem: line 13: : orden no encontrada
    /etc/init.d/iniciarmodem: line 14: : orden no encontrada
    /etc/init.d/iniciarmodem: line 15: : orden no encontrada
    /etc/init.d/iniciarmodem: line 16: : orden no encontrada
    /etc/init.d/iniciarmodem: line 17: : orden no encontrada
    /etc/init.d/iniciarmodem: line 18: : orden no encontrada
    /etc/init.d/iniciarmodem: line 19: : orden no encontrada
    /etc/init.d/iniciarmodem: line 20: : orden no encontrada
    /etc/init.d/iniciarmodem: line 21: : orden no encontrada
    /etc/init.d/iniciarmodem: line 22: : orden no encontrada
    /etc/init.d/iniciarmodem: line 12: : orden no encontrada
    /etc/init.d/iniciarmodem: line 13: : orden no encontrada
    /etc/init.d/iniciarmodem: line 14: : orden no encontrada
    /etc/init.d/iniciarmodem: line 15: : orden no encontrada
    /etc/init.d/iniciarmodem: line 16: : orden no encontrada
    /etc/init.d/iniciarmodem: line 17: : orden no encontrada
    /etc/init.d/iniciarmodem: line 18: : orden no encontrada
    /etc/init.d/iniciarmodem: line 19: : orden no encontrada
    /etc/init.d/iniciarmodem: line 20: : orden no encontrada
    /etc/init.d/iniciarmodem: line 21: : orden no encontrada
    /etc/init.d/iniciarmodem: line 22: : orden no encontrada
    /etc/init.d/iniciarmodem: line 12: : orden no encontrada

    y es mas largo pero un poco monotono para postiarlo aca…

    pero termina con esta frase:

    The SpeedTouch firmware did not load

    QUe puedo hacer????

    gracias


  13. Ese error lo resolvió condor en la 3ra página de su guia. Según él, el problema radica en que esta mal escrito el script.

    Lo que hizo el usuario con ese problema fue escribir el contenido manualmente, aunque yo no lo veo necesario ya que si lo copias desde la página (nada de pasarlo antes a un editor de texto) debería funcionar de manera correcta.

    Mi consejo es que, en una instalación limpia de Ubuntu (a poder ser, recién instalada hagas el proceso basándote en la guia de condor y revisando algún detalle en esta (si no estas algo familiarizado algunas cosas de ahí te pueden confundir).

    A ver si ahora funciona 🙂 .


  14. hice todo lo que sale en la guia y me surgieron errores nuevos.. (resulevo uno y aparece otro) … de hecho ya le deje un post a condor.. pero no se si el este disponible actualemente para responderme…

    asi q por si acaso te pregunto a ti…
    mira hice lo q la guia decia en la pag 3-4

    te voy a copiar lo q le pregunte a condor y ahi estan los errores q t menciono:

    sebastian@sebast:~$ sudo /etc/init.d/iniciarmodem
    br2684ctl[7551]: Interface “nas0” could not be created, reason: File exists
    br2684ctl[7551]: Communicating over ATM 0.8.35, encapsulation: LLC
    br2684ctl[7551]: Fatal: failed to connect on socket
    Plugin rp-pppoe.so loaded.

    hice lo q señalas anteriormente ya q tenia el mismo error y me salio

    en las ultimas lineas:

    [ 43.209214] ATM dev 0: ADSL line: exchange
    [ 44.197591] ATM dev 0: ADSL line: up (672 kb/s down | 128 kb/s up)
    [ 160.908292] PPP generic driver version 2.4.2
    [ 160.941605] NET: Registered protocol family 24
    [ 174.136080] NET: Registered protocol family 17
    [ 174.159000] NET: Registered protocol family 10
    [ 174.159185] lo: Disabled Privacy Extensions
    [ 174.159364] ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 184.598016] nas0: no IPv6 routers present
    [ 185.122269] br2684_create: register_netdev failed

    luego segui instrucciones de otros posts y me da:

    sebastian@sebast:~$ sudo cat /var/log/syslog | grep -i atm
    Jan 15 15:21:01 sebast kernel: [ 33.348440] ATM dev 0: ADSL state: stopped
    Jan 15 15:21:01 sebast kernel: [ 33.348446] ATM dev 0: ADSL line: down
    Jan 15 15:21:01 sebast kernel: [ 35.067754] ATM dev 0: ADSL state: running
    Jan 15 15:21:01 sebast kernel: [ 35.067759] ATM dev 0: ADSL line: attempting to activate
    Jan 15 15:21:08 sebast kernel: [ 45.058408] ATM dev 0: ADSL line: training
    Jan 15 15:21:10 sebast kernel: [ 47.055183] ATM dev 0: ADSL line: channel analysis
    Jan 15 15:21:14 sebast kernel: [ 51.065592] ATM dev 0: ADSL line: exchange
    Jan 15 15:21:15 sebast kernel: [ 52.050964] ATM dev 0: ADSL line: up (672 kb/s down | 128 kb/s up)
    Jan 15 15:56:04 sebast kernel: [ 31.533144] ATM dev 0: ADSL state: stopped
    Jan 15 15:56:04 sebast kernel: [ 31.533149] ATM dev 0: ADSL line: down
    Jan 15 15:56:04 sebast kernel: [ 32.874275] ATM dev 0: ADSL state: running
    Jan 15 15:56:04 sebast kernel: [ 32.874280] ATM dev 0: ADSL line: attempting to activate
    Jan 15 15:56:04 sebast kernel: [ 35.874370] ATM dev 0: ADSL line: training
    Jan 15 15:56:06 sebast kernel: [ 37.872141] ATM dev 0: ADSL line: channel analysis
    Jan 15 15:56:10 sebast kernel: [ 41.863564] ATM dev 0: ADSL line: exchange
    Jan 15 15:56:11 sebast kernel: [ 42.867930] ATM dev 0: ADSL line: up (672 kb/s down | 128 kb/s up)
    Jan 15 16:00:06 sebast br2684ctl[7525]: Communicating over ATM 0.8.35, encapsulation: LLC
    Jan 15 16:00:31 sebast br2684ctl[7551]: Communicating over ATM 0.8.35, encapsulation: LLC
    Jan 15 16:13:23 sebast kernel: [ 31.980376] ATM dev 0: ADSL state: stopped
    Jan 15 16:13:23 sebast kernel: [ 31.980380] ATM dev 0: ADSL line: down
    Jan 15 16:13:23 sebast kernel: [ 33.209564] ATM dev 0: ADSL state: running
    Jan 15 16:13:23 sebast kernel: [ 33.209569] ATM dev 0: ADSL line: initializing
    Jan 15 16:13:23 sebast kernel: [ 34.198938] ATM dev 0: ADSL line: attempting to activate
    Jan 15 16:13:24 sebast kernel: [ 37.199031] ATM dev 0: ADSL line: training
    Jan 15 16:13:26 sebast kernel: [ 39.211767] ATM dev 0: ADSL line: channel analysis
    Jan 15 16:13:30 sebast kernel: [ 43.209214] ATM dev 0: ADSL line: exchange
    Jan 15 16:13:31 sebast kernel: [ 44.197591] ATM dev 0: ADSL line: up (672 kb/s down | 128 kb/s up)
    Jan 15 16:15:28 sebast br2684ctl[7556]: Communicating over ATM 0.8.35, encapsulation: LLC
    Jan 15 16:15:52 sebast br2684ctl[7587]: Communicating over ATM 0.8.35, encapsulation: LLC
    Jan 15 16:17:22 sebast br2684ctl[7646]: Communicating over ATM 0.8.35, encapsulation: LLC

    q puedo hacer?? me podrias ayudar???


  15. La verdad que solucionarte el problema me es cuasi imposible, pero normalmente hay varios caminos a seguir, tomemos otro.

    1) Baja este archivo (http://rapidshare.com/files/84094072/Modem.tar.gz) y descomprimelo en tu carpeta personal (/home/sebastian).
    2) Cambia los parámetros del archivo dsl-provider por los que correspondan a tu servicio.
    3) Abre consola y ejecuta estos comandos, uno por uno:

    sudo cp cxacru-fw.bin /lib/firmware/
    sudo dpkg -i br2684ctl_20040226_1_i386.deb
    sudo cp dsl-provider /etc/ppp/peers
    sudo cp iniciarmodem /etc/init.d
    sudo cp iniciarmodembackground /etc/init.d
    cd /etc/init.d
    sudo chmod +x iniciarmodem
    sudo chmod +x iniciarmodembackground
    cd /etc/rc2.d
    sudo ln -s /etc/init.d/iniciarmodembackground S95iniciarmodem

    4) Reinicia, anda a tomar un poco de agua que seguro te dio sed y cuando vuelvas pruebas si anduvo ^^. (Esto último, no necesitas tomar algo, pero si dale un tiempito)

    Lo único que te pido es que lo hagas en una instalación limpia de Ubuntu, si es necesario que lo instales nuevamente para así no lidiar con problemas anteriores.

    Ya me dirás como te fue 😉 .


  16. Buenas compañeros mi problema es el siguiente, resido en Panamá y tengo un modem 630-c de Zyxel he tratado de hacer lo que dice aqui en el post pero no me ha resultado, a la hora de conectarme nunca debo validarme al menos en mi pc la conexión siempre esta, no necesito poner user ni password.
    He seguido los pasos y hasta ahora han encendido las luces del modem pero luego no se que poner en user y en password ya que no los utilizo para poder conectarme, saludos desde Panamá.


  17. Debe ser porque usas PPPoA, no creo que este tutorial sirva para eso.

    En tu caso, la configuración es desde la aplicación interna del modem (como los motorola de Arnet en Argentina).


  18. amigo me da un error en :

    /usr/sbin/pppd: In file /etc/ppp/peers/dsl-provider: unrecognizer option `nas0´



Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: